[obspy-users] Obspy 1.0.0 no read module

gonzalo antonio fernandez marañon tonino.gafm at gmail.com
Mon Mar 21 02:53:33 CET 2016


Dear Forum.

I just finished updating my obspy from 0.10.2 to 1.0.0 in Windows 7
(python 2.7.3) and any module is working.

When I type.

from obspy import read

I got the error:

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.mseed' is deprecated and will
stop working with the next ObsPy version. Please import module
'obspy.io.mseed' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.mseed.core' is deprecated and
will stop working with the next ObsPy version. Please import module
'obspy.io.mseed.core' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.mseed.core.readMSEED' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.mseed.core._read_mseed' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.sac' is deprecated and will
stop working with the next ObsPy version. Please import module
'obspy.io.sac' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.sac.core' is deprecated and
will stop working with the next ObsPy version. Please import module
'obspy.io.sac.core' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.sac.core.readSAC' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.sac.core._read_sac' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.gse2' is deprecated and will
stop working with the next ObsPy version. Please import module
'obspy.io.gse2' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.gse2.core' is deprecated and
will stop working with the next ObsPy version. Please import module
'obspy.io.gse2.core' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.gse2.core.readGSE2' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.gse2.core._read_gse2' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.seisan' is deprecated and will
stop working with the next ObsPy version. Please import module
'obspy.io.seisan' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.seisan.core' is deprecated and
will stop working with the next ObsPy version. Please import module
'obspy.io.seisan.core' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.seisan.core.readSEISAN' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.seisan.core._read_seisan' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.sac.core.readSACXY' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.sac.core._read_sac_xy' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.gse2.core.readGSE1' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.gse2.core._read_gse1' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.sh' is deprecated and will stop
working with the next ObsPy version. Please import module
'obspy.io.sh' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.sh.core' is deprecated and will
stop working with the next ObsPy version. Please import module
'obspy.io.sh.core' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.sh.core.readQ' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.sh.core._read_q' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\deprecation_helpers.py",
line 57
    warnings.warn(msg, ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Function 'obspy.io.sh.core.readASC' is
deprecated and will stop working with the next ObsPy version. Please
use 'obspy.io.sh.core._read_asc' instead.

Warning (from warnings module):
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 157
    ObsPyDeprecationWarning)
ObsPyDeprecationWarning: Module 'obspy.core.ascii' is deprecated and
will stop working with the next ObsPy version. Please import module
'obspy.io.ascii' instead.

Traceback (most recent call last):
  File "<pyshell#8>", line 1, in <module>
    from obspy import read
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\__init__.py",
line 179, in <module>
    read.__doc__ % make_format_plugin_table("waveform", "read", numspaces=4)
  File "C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\core\util\base.py",
line 517, in make_format_plugin_table
    "obspy.plugin.%s.%s" % (group, name), method)
  File "C:\Python27\lib\site-packages\distribute-0.6.49-py2.7.egg\pkg_resources.py",
line 345, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "C:\Python27\lib\site-packages\distribute-0.6.49-py2.7.egg\pkg_resources.py",
line 2381, in load_entry_point
    return ep.load()
  File "C:\Python27\lib\site-packages\distribute-0.6.49-py2.7.egg\pkg_resources.py",
line 2092, in load
    raise ImportError("%r has no %r attribute" % (entry,attr))
ImportError: <module 'obspy.io.ascii' from
'C:\Python27\lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy\io\ascii\__init__.pyc'>
has no 'readSLIST' attribute


I did the same with.

from obspy.core import read    --> same result.

I updated the version using the easy_install obspy from the cmd.

it created many folders:

C:\Python27\Lib\site-packages\obspy-1.0.0-py2.7-win-amd64.egg\obspy

Thanks in advance for your time.

Best regards.

Tonino


More information about the obspy-users mailing list