[obspy-users] SeismoSocialDistancing.ipynb, warning message

Tobias Megies megies at geophysik.uni-muenchen.de
Thu Jun 25 11:55:18 CEST 2020


Hi Alan,

thanks for letting us know, we'll have to adapt obspy code to this API
change, I made a ticket:
https://github.com/obspy/obspy/issues/2652

cheers,
Tobias

On 24/06/2020 15:02, Alan Kafka wrote:
> Hi,
> 
> I’m running SeismoSocialDistancing.ipynb, and I’m getting this warning message:
> 
> C:\Users\Observatory\anaconda3\envs\obspy\lib\site-packages\obspy\signal\spectral_estimation.py:2096: MatplotlibDeprecationWarning: 
> The set_clim function was deprecated in Matplotlib 3.1 and will be removed in 3.3. Use ScalarMappable.set_clim instead.
>   cb.set_clim(*fig.ppsd.color_limits)
> 
> (The program still runs fine, and the output looks right to me.)
> 
> Any suggestions?
> 
> Thanks,
> 
> ~ Alan Kafka
> 
> 



More information about the obspy-users mailing list